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Map3-2D documentation

Version 1.0

Introduction

This software is prepared to work with 5D images or, in other words, multi-channel time-lapse 3D
stacks. The bit depth of these multi-dimensional images is set at the acquisition stage, but could also
be modified in a pre-processing stage. In any case, the bit depth is the same for every image in the
5D stack.

Map3-2D allows the addition of extra channels. Those additional channels can have different bit
depths (8 or 16 bit integer, 32 bit float). They can be added by the user (see Image Menu) or created
by the software during certain processes like, for example, the creation of a projection.

On top of the main and extra channels, one or two masks can be appended to the current image.
These masks are binary 3D or 3D+time stacks that are used to select certain 3D regions of the (5D)
image. Users can load these masks from a file or from a channel of the current image. Pixels (voxels)
with zero values are considered false and the rest true.

Together with the main graphical interface a small dialog, called ‘Log...", shows the current operation
running. This dialog also provides a Recovery button to recover halted software. Upon recovery,
please, keep in mind that an update on the images might be necessary (for example, by adjusting
properties in the 2D projections).

The next sections provide an overview of the graphical interface and a detailed description of the
main menu.
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Main graphical interface

The visual appearance of the main graphical interface is shown here. It consists of the central image
area with the menu bar and the toolbar on top, a sidebar on the right and 3 sliders at the bottom.
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From the left to the right, the toolbar provides information of the current pixel coordinates and its
intensity value followed by two buttons for panning and zooming. A popup menu with the current
color map or lookup table (LUT) of the current channel allows the user to freely change the LUT. As
images could have a width/height proportion different from the image area in the window, the user
can stretch it to fully fit in the window by activating the Stretch checkbox.

The Masked checkbox is enabled when the “Mask 1” is defined (see Image menu). When checked
those parts of the image which are not part of the mask are display as background. The user can
define the background value for each channel (see Image menu).

For display range control, it is possible to set the minimum and maximum value, to estimate the best
display range without saturation (Auto button) or to reset the display to the full bit depth of the
channel (Reset button). The Auto button combined with the [Ctrl] and/or [Shift] keys considers all the
slices and/or all the frames in the estimation of the display range, respectively. Each channel has its
own display range and has to be adjusted independently.

The last two controls of the toolbar are shortcuts to create 2D selections. The popup menu provides
a whole set of possibilities: point, line, rectangle, ellipse, polygon and free-hand selections. The Select
button is used to recreate the current selection. However, combined with the [Ctrl] key it removes
the current selection. Only one selection can exist at a time (see Selection Menu).
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Sliders
By moving the sliders at the bottom of the window the user can navigate within the hyper-stack
(channel/z-slice/time frame). The numbers left to the sliders display (and allow for manual changes
of) the current channel/Z-slice/time frame.

Sidebar
The sidebar manages regions of interest (ROI) and is called ROl Manager.
The box in the middle lists all ROls. ROls can be created in two ways:

* adding a 2D selection with the Add button, or

¢ getting it from another image through the Transfer button

After a 2D ROl is transferred it can become 3D depending on the kind of connection between the
images.

By clicking on the list box together with the [Ctrl] / [Shift] keys the user can select/deselect one or
more ROIls. There are two checkboxes over the ROI list box: Keep updated and 2D selections. The first
one updates the ROIs when the user change the current image (channel or frame), while the second
one is used to show 2D selections even when they were not created in the current slice.

The buttons below the list box are shortcuts to the Selection Menu (See Selection Menu).

File Menu

File->Open

The Map3-2D software is designed to work only with “Tiff or BigTiff” files. As Imagel/FlJl is one of the
most popular image processing software for scientific research, it is prepared to open hyper-stacks
saved in the “Image) Tiff” format.

It is recommended to use Imagel/FlJl to prepare the hyper-stack before opening in Map3-2D.

If a different folder than the default one is used to open the file, the software will ask if this should
be considered the project folder (see File->Project folder).

Immediately after opening an image or stack, a dialog will pop up to adjust the voxel size. The
software is prepared to automatically read it from files saved by Imagel/FlJI (see Image->Voxel Size).

File->Save

A dialog will pop up allowing the user to decide whether to save the main and/or additional
channels. If the mask 1 is defined, the second checkbox is enabled to allow the application of the
mask on the main channels. In case of saving additional channels, the user can decide which channels
to save, optionally, in independent files, bundled together in one file but separated from the main
channels or bundled together with the main channels. The bit depth for each file is always adjusted
to the largest bit depth of the channels saved.

Map3-2D uses only the “BigTiff” format to save images, which can be opened straightforward in

Imagel/FlJI (using the Bioformats library). Depending on the amount of data, the saving process can
take several minutes.
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File->Project folder

This software follows a project approach, meaning the the user can determine the folder where to
save the project. Every new map created will be, by default, saved in a subfolder of the project
folder.

Selection menu

Selection -> Make selection

This option allows the user to make a 2D selection (point, line, rectangle, ellipse, polygon and free
hand). The selection remains on the figure until either another selection is placed or it is removed or
added to the RoiManager.

Selection -> Clear selection

Remove the current selection. The same effect can be achieved with the toolbar button “Select” by
pressing [ctrl] + click.

Selection -> Repeat selection

The current selection is removed and the user can repeat another one. The same effect can be
achieved with the toolbar button “Select”.

Selection -> Add to ROI Manager
The current selection is added to the list of the ROl Manager. Upon addition it cannot be modified
again.

Selection -> Delete ROI
The currently selected ROl is deleted from the ROl Manager

Selection -> ROI properties
A dialog pops up to change the name of the ROl in the ROl Manager list.

Selection -> Select all ROIs
All the ROIs in the ROl Manager are selected or deselected.

Selection -> Measure

Performs several measurements of the area selected by the ROl (mean, median, minimum,
maximum, volume/area, centroid, etc.). Only visible 2D ROIs are considered while in the case of 3D

Sendra, G.H. & Lorenz, H. 4



Z
Imaging ¥Facility
F{

ROIs the measurements are performed on the whole stack. Different type of measurements can be
achieved in combination with the keyboard:

2D ROIs 3D ROIs
Click Only if visible in the current slice Whole 3D stack
[Ctrl] + click Only if visible in the current slice Only what is visible in the current slice
[Shift] + click Not measured Measured
[Alt] + click Measure on every frames Measure on every frame

Note: The [Ctrl], [Shift] and [Alt] keys can be combined together.

If no ROl is selected, the measurements will be performed over the whole image/stack.

Selection -> ROI operations
A dialog pops up and, when there are more than one selected ROI, logical operations like AND, OR
and XOR are performed to create a new ROL.
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Selection -> Draw ROI
ROIs can also be drawn (or burned) into the current image. This operation modifies permanently the
image and there is no undo operation. When the user selects “Draw ROI” the following dialog pops

up.

The user must give a value to the border, but can decide whether to draw also on the inside of the
ROI (Draw also foreground checkbox) and, in such a case, if it will have the same value or not. In the
case of 3D ROls, a 3D erosion is applied in order to determine the inside volume.

For the case of 3D ROls, it is possible to decide whether to draw only the current slice or all the slices
where the ROl appears.
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It is also possible to draw 2D ROIs (which come from selections) onto every slice (Draw 2D ROIs on
every slice checkbox).

Finally, the last checkbox allows the user to draw the ROl on every frame.

Border Value: 255

Draw also Foreground
Same value as border
Foreground Value: 255
Draw full 3D ROIs
[7] Draw 2D ROls in every slice

["] Draw ROls in every frame

[ Cancel H Apply ]

Selection -> Transfer

Each window can have child windows, like for example the 2D projections windows. It is possible to
transfer the selected ROIs to either the child window or the parent window with this command. A
dialog pops up to select the destination window(s) (multiple destinations can be selected at the same
time by pressing [Ctrl] and/or [Shift] keys). If the transfer is done from a child window, the
destination can only be the main window (i.e. the main graphical interface).

[ Transter . e nainimSee

Destination of the ROls:

Map-1-copy
Map-1-copy-copy

[ Cancel H Apply ]

Selection -> Load ROls...
Previously saved ROls are loaded. It cannot import files from other software.

Selection -> Save ROIs
It saves current selected ROIs in a file. It cannot export the ROIs to be opened in another software.

Selection -> ROI color
A dialog pops up to change the color used by the software to show the ROIs. It is defined as an RGB
color.
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Image menu

Image -> Voxel size...
This option allows the user to change the size of the voxels. A correct voxel size is crucial for the 2D
projection. This dialog can also be used to remove the current voxel size, i.e. setting all values to 1.

Voxel width (X): 10
Voxel height (Y): 20
Voxel depth (2): 30
l Remove ] l Cancel ] l Apply ]

This dialog also pops up every time a new image is opened. The software tries to determine the voxel
size from the metafile in the Tiff figure, but it only works with Tiff files saved with the Imagel/FlJI
software.

Image -> Channel background value...

When masks are used, the unmasked areas are shown as background. The value of the background
can be set by the user individually for every channel.

|

Background value: 50

[] Apply to all channels

Image -> Add Mask 1 (object/surface) / Add Mask 2 (object/surface)
These two commands open a dialog to define the first or second mask. The first mask is used to
define the region of the object/surface to be analyzed, while the second one can optionally be used

as a reference in the 2D projections.
. S

Mask name: Mask-1

© Load from an image stack file

*) Use self image as mask
Channel: 1

Frames: -All-

Cancel Continue

Two options are available to define a mask:
* load from an image stack file, or
* Use self image as mask.

In the first case only the first channel of the loaded hyper-stack will be considered, while in the other
option the user can decide which channel and frame is going to be employed.

It is important to emphasize that the software considers zero values as unmasked region and
everything else as masked.

Image -> Add extra channel
An additional channel is added to the image. The bit depth is the same as the main channels.
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Image -> Remove current channel
It removes the current channel. At least one main channel must remain.

Image -> Remove all extra channels
It removes all additional channels.

2D projections

As soon as you click on Process -> 2D projection at the menu bar, a new image window is displayed
and a dialog pops up in order to set the properties of the projection.

Properties dialog

Project options Unfolding options Map image options

Subfolder name: Unfolding axis: +Z Height effects:

Map-2 Central longitude: (] Weight latitudes

Map filename: [] Weight longitudes

Reference axis:

Map-2 | . _
2 Shift: Height factor:

j J Radius (R):

Border projection:  Mean

Import properties from file_.. Geographical table size:

Fitting options Latitudes: 90 Interpolation: Cubic

Current approximation: Longitudes: 180 Map Size: Auto

Oblate Ellipsoid (algebraic) Height: 500
Mask-1 / Ref. frame:1

Width: 500

. Projection:
Fitting mask: Mask-1

Equirectangular ' Grid lines settings:
Reference frame: 1 )

Projection parameters: [ Latides H Lojotudes ]

Estimation method:

Parameter

Oblate Ellipsoid (algebrai
ate Ellipsoid (algebraic) Standard parallel B 255

Estimate ] [ Adjust

Cancel

Subfolder name

This is a subfolder of the project folder and it is intended to be the place for saving the 2D projections
(one or more). The chosen properties will also be saved automatically in this folder with the file
extension “.emp”.

Map filename
This is the name for the projection, which will be used as the window title and also as filename for
properties “.emp”.

Import properties from file
This button is used to import the properties from a previously saved properties “.emp” file.
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Current approximation
In this box the software shows the current approximation of the reference ellipsoid that is used for
the 2D unfolding. The mask employed as well as the reference frame are written in the second line.

Fitting mask
If the Mask 2 is defined then the user can decide whether to use Mask 1 or Mask 2 for the estimation
of the reference ellipsoid.

Reference frame

If the chosen mask contains more than one frame, then the user can decide which frame will be used
for the estimation of the reference ellipsoid. It is also possible to select all of them. In such a case, a
time maximum projection will be done. No changes will be applied until the button Estimate is
pressed.

Estimation method

The user can select here if a sphere, oblate ellipsoid or tri-axial ellipsoid for the estimation is applied.
It is recommended to use, for example, the Imagel/FlJI 3D Viewer plugin to get an idea of the shape
of the sample/mask. No changes will be executed until the button Estimate is pressed.

Estimate button

By clicking on this button the reference ellipsoid will be re-estimated based on the Fitting mask,
Reference frame and Estimation method. The previous parameters of the reference ellipsoid will be
deleted and the only way to recover them is by pressing the Cancel button.

Adjust button

As the estimation of the reference ellipsoid is based on an algebraic approximation, it is often not the
best fit. Apart from that, some samples are not exactly a sphere or symmetrical ellipsoid. Due to
these reasons, the user can manually adjust the ellipsoid by pressing this button. A new Fitting
adjustment dialog will pop up and will be described later (see Fitting adjustment dialog).

Unfolding axis

The most common maps of the Earth are based on the unfolding around the rotation axis (north-
south axis). With this popup menu, Map3-2D allows the user to select the X, Y or Z unfolding axis.
This axis is directly related with the latitudes, which are on the [-90°, 90°] range, corresponding to the
negative and positive semi-axis respectively. There are also “flipped” versions of the axes in which
case the negative latitudes are on the positive semi-axis and the positive latitudes on the negative
semi-axis.

In order to have a better visualization of the axes directions it is recommended to go to the Fitting
adjustment dialog by clicking on the Adjust button.

Central longitude

The central longitude of the 2D projection is equivalent to the Greenwich meridian in the common
maps of the Earth. After selecting the unfolding axis, the central meridian can be chosen in the
Reference axis popup menu as any of the other four semi-axes.

The resulting longitude values will be in the range [-180°, 180°] and the direction of the non-used axis
(neither as unfolding axis nor as central longitude) determines the direction of the increments in the
longitudes.

The central longitude can be shifted to an exact value by using the Shift slider or edit control.

Geographical table size

For the 2D projections the Map3-2D software uses an intermediate table of latitudes and longitudes
called Geographical table. This table establishes the resolution in latitudes and longitudes for the
map. The resolution might not be linear since it depends on the projections.
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The Estimate button finds the best size based on the ellipsoid semi-axes and the voxel size. However,
this value should be manually adjusted to get better looking maps.

Projection

The user can select among the available projections in the popup menu (Equirectangular, Mercator,
Braun, Miller, Lambert-Cylindrical, Sinusoidal, Mollweide, Wagner-VI and Bonne). Some of the
projections include parameters that can be adjusted in the table below.

More information about these projections can be found, for example, on Wikipedia.org (List of map
projections).

Height effects

Map3-2D software allows also the weighting of the latitudes and/or longitudes map positions by the
height (or elevation) with respect to the reference ellipsoid. A radius value is added to the weights in
order to avoid negative values. This radius can be the local ellipsoid radius for the current (latitude,
longitude) or the maximum radius for the whole ellipsoid.

A height factor can also be applied to increase or reduce the height influence.

Border projection

If the mask is thick, more than one pixel will probably have the same latitude and longitude.
Consequently they will overlap in the geographical table and hence in the resulting map. With the
Border projection popup menu it is possible to choose between mean, maximum, minimum or sum
operations to deal with the overlapping pixels.

Unfortunately this effect is not only caused by the surface thickness but also by the sampling of the
geographical table. This is another good reason to manually adjust the geographical table size, if
needed.

Interpolation

During the unfolding there are parts of the map that might not contain any value. This effect appears,
for example, on the pole regions for the cylindrical projections or when there are gaps in the
geographical table where there are no values. These values can be interpolated with different
interpolation methods: nearest, linear, natural, and cubic.

Map size
The map size (height and width) is controllable by the user. By clicking on the Auto checkbox, the size
of the map will be the same as the geographical table size.

Grid lines settings

The resulting 2D projection contains a first additional channel, called grid channel, with the meridian
parallel lines, as in the case of the Earth maps. The number of lines as well as their individual colors
(intensity values) can be adjusted with the Latitudes and Longitudes buttons. These buttons will open
a window with a two-columns table where the first column contains the latitudes/longitudes lines
and the second the corresponding intensity values:
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Options Options
Latitude | Color Value Longitude | Color Value
1 -75 100 -180 100 -
2 -60 110 -165 104.3478
3 -45 120 -150 108.6957
| 4 | -30 130 -135 113.0435
5 | -15 140 -120 117.3913
6 0 150 -105 121.7391
7 15 160 -0 126.0870
8 30 170 -75 130.4348
9 45 180 -60 1347826 =
10 60 190 -45 139.1304
| 11 | 75 200 -30 143.4783
-15 147.8261
0 1521739
15 156.5217
30 160.8696
45 1652174
60 169.5652
75 173.9130
90 178.2609
105 182.6087 ot
—
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In the Options menu there are commands to add/remove lines and to reset the table for the default

values.

Apart from the intensity of the latitude and longitude lines (or parallels and meridians), there is a line
for the border of the map whose intensity values can be adjusted with the Border color edit box.

Apply

By pressing Apply the map will be created or updated.

Cancel

The Cancel button will also close the map image window if the map was not created before. It will
not update the map image.

Fitting adjustment dialog

Manual fitting

Current approximation:

Fitting mask: Mask-1 v
Reference frame: 1 v
Estimation method:

Sphere (algebraic) v

Estimate

Ellipsoid center:

X Y Z
14.2778 || || 13.4855 | | 13.4725

Ellipsoid orientation:

X Axis Y Axis Z Axis

1 0 0
0 1 0
0 0 1

Positive semi-axes:

a b c
9.4779 9.4779 9.4779

Negative semi-axes:

a b c
9.4779 9.4779 9.4779

. 4| Fitting adjustment..

[Orientatlon] ‘ Semi-axes l

Center

Rotation around

Axis Direction

Angle:

z

Cancel

Apply \
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The Fitting adjustment dialog is a graphical interface to visually adjust the reference ellipsoid position
and rotation, as well as each individual semi-axis length. It shows three images, each of them
corresponding to the maximum intensity projection of the mask in the X, Y and Z directions. Every
axis has its own color and the position of the letter (x, y or z) indicates the positive semi-axes. For the
third axis there is a circle with a cross, denoting that this axis increases its values towards behind the
screen.

Manual fitting

The controls on top of the left panel (Manual fitting) to estimate the reference ellipsoid are the same
as in the Properties dialog. It is also possible to write the exact value for the Ellipsoid center, Ellipsoid
orientation, as well as Positive and Negative semi-axes.

Three vectors representing the axes of the real ellipsoid define the orientation, the perpendicularity
between them must be kept.

Upon changes, the Update button must be pressed to actually apply the changes.

It is strongly recommended not to change these parameters here but instead using the bottom
right panel, as described below.

Orientation

This button transforms the bottom right panel to adjust the axes direction. The user can decide
around which axis to rotate in the Rotation around popup menu, and then write the Angle or adjust it
with the slider.

Semi-axes

This button transforms the bottom right panel to adjust the semi-axes length. The user can decide
which Semi-axis to modify with a popup menu, and then write the Length or adjust it with the slider.
There is also a checkbox to adjust simultaneously the positive and negative semi-axes in case of a
symmetrical ellipsoid.

Center

This button transforms the bottom right panel to adjust the position of the ellipsoid. The user can
decide which Axis to adjust with a popup menu, and then write the Displacement or adjust it with the
slider.

Confirm
The current adjustment will become permanent, allowing the user to proceed to the next
adjustment. There is no order for the adjustments, but each step must be confirmed.

Restore
In case the user is not satisfied with the new adjustments, it is possible to restore the ellipsoid to any
of the previous stages.

Reset
The current adjustments are reset to the current ellipsoid parameters.

Apply
By pressing Apply the reference ellipsoid will be updated in the Properties dialog.

Cancel
The Cancel button will not update the reference ellipsoid in the Properties dialog.
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The 2D projection window

Once the 2D projection is created, the result is displayed in a window that is very similar to the main
graphical interface. The image has as many main channels as the original one plus 2 additional
channels: the grid and the height channels. The first one reproduces the parallel and meridian lines
as in Earth maps, while the second is like a cartographic relief depiction where the baseline is
determined by the reference ellipsoid.

There are only a few differences in the menu bar, some commands were removed and some others
were added, as described below:

File -> Duplicate Map
This command duplicates the map in a new window. It is very useful to compare different maps of
the same object.

Map -> Transfer Grid

This command transfers the 2D grid channel to an additional channel in the original stack image.
Consequently the 2D image with the grid is transformed into a 3D stack.

Map -> Transfer Heights

This command also creates an additional channel in the original stack image, where the values of
mask 1 now contain real values (float) representing the shortest distance to the reference ellipsoid.
These values are actually the height with respect to the reference ellipsoid.

Map -> Transfer Ellipsoid with Heights

This command creates an additional channel in the original stack image, which contains the
reference ellipsoid, whose pixel (voxel) intensities are the average height for the corresponding
latitudes and longitudes.

Map -> Properties
By clicking this command the user can modify the properties of the current 2D projection (see
Properties dialog)
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